UBUNTU: [Config] Linearize module/abi checks
[linux-flexiantxendom0-natty.git] / debian / rules.d / 4-checks.mk
1 # Check ABI for package against last release (if not same abinum)
2 $(abidir)/%: $(stampdir)/stamp-build-%
3         install -d $(abidir)
4         sed -e 's/^\(.\+\)[[:space:]]\+\(.\+\)[[:space:]]\(.\+\)$$/\3 \2 \1/'   \
5                 $(builddir)/build-$*/Module.symvers | sort > $@
6
7 abi-check-%: $(abidir)/%
8         @perl -f $(DROOT)/scripts/abi-check "$*" "$(prev_abinum)" "$(abinum)" \
9                 "$(prev_abidir)" "$(abidir)" "$(skipabi)"
10
11 # Check the module list against the last release (always)
12 $(abidir)/%.modules: abi-check-%
13         install -d $(abidir)
14         find $(builddir)/build-$*/ -name \*.ko | \
15                 sed -e 's/.*\/\([^\/]*\)\.ko/\1/' | sort > $@
16
17 module-check-%: $(abidir)/%.modules
18         @perl -f $(DROOT)/scripts/module-check "$*" \
19                 "$(prev_abidir)" "$(abidir)" $(skipmodule)
20
21 checks-%: module-check-%
22         @# Will be calling more stuff later
23
24 # Check the config against the known options list.
25 config-prepare-check-%: $(stampdir)/stamp-prepare-tree-%
26         @perl -f $(DROOT)/scripts/config-check \
27                 $(builddir)/build-$*/.config "$(arch)" "$*" "$(sharedconfdir)" "$(skipconfig)"
28
29 prepare-checks-%: config-prepare-check-%
30         @# Will be calling more stuff later