UBUNTU: [Config] Add support for cross compiling armel
[linux-flexiantxendom0-natty.git] / debian / rules.d / 1-maintainer.mk
1 # The following targets are for the maintainer only! do not run if you don't
2 # know what they do.
3
4 .PHONY: printenv updateconfigs printchanges insertchanges startnewrelease diffupstream help updateportsconfigs editportsconfigs
5
6 help:
7         @echo "These are the targets in addition to the normal $(DEBIAN) ones:"
8         @echo
9         @echo "  printenv        : Print some variables used in the build"
10         @echo
11         @echo "  updateconfigs        : Update core arch configs"
12         @echo
13         @echo "  editconfigs          : Update core arch configs interractively"
14         @echo "  genconfigs           : Generate core arch configs in CONFIGS/*"
15         @echo
16         @echo "  updateportsconfigs   : Update ports arch configs"
17         @echo
18         @echo "  editportsconfigs     : Update ports arch configs interactivly"
19         @echo "  genportconfigs       : Generate ports arch configs in CONFIGS/*"
20         @echo
21         @echo "  printchanges    : Print the current changelog entries (from git)"
22         @echo
23         @echo "  insertchanges   : Insert current changelog entries (from git)"
24         @echo
25         @echo "  startnewrelease : Start a new changelog set"
26         @echo
27         @echo "  diffupstream    : Diff stock kernel code against upstream (git)"
28         @echo
29         @echo "  help            : If you are kernel hacking, you need the professional"
30         @echo "                    version of this"
31         @echo
32         @echo "Environment variables:"
33         @echo
34         @echo "  NOKERNLOG       : Do not add upstream kernel commits to changelog"
35         @echo "  CONCURRENCY_LEVEL=X"
36         @echo "                  : Use -jX for kernel compile"
37         @echo "  PRINTSHAS       : Include SHAs for commits in changelog"
38
39 printdebian:
40         @echo "$(DEBIAN)"
41
42 updateconfigs:
43         dh_testdir;
44         $(SHELL) $(DROOT)/scripts/misc/kernelconfig oldconfig
45         rm -rf build
46
47 defaultconfigs:
48         dh_testdir;
49         yes "" | $(SHELL) $(DROOT)/scripts/misc/kernelconfig defaultconfig
50         rm -rf build
51
52 editconfigs:
53         dh_testdir
54         $(SHELL) $(DROOT)/scripts/misc/kernelconfig editconfig
55         rm -rf build
56
57 genconfigs:
58         dh_testdir
59         $(SHELL) $(DROOT)/scripts/misc/kernelconfig genconfig
60         rm -rf build
61
62 updateportsconfigs:
63         dh_testdir;
64         $(SHELL) $(DROOT)/scripts/misc/kernelconfig oldconfig ports
65         rm -rf build
66
67 editportsconfigs:
68         dh_testdir
69         $(SHELL) $(DROOT)/scripts/misc/kernelconfig editconfig ports
70         rm -rf build
71
72 genportsconfigs:
73         dh_testdir
74         $(SHELL) $(DROOT)/scripts/misc/kernelconfig genconfig ports
75         rm -rf build
76
77 printenv:
78         dh_testdir
79         @echo "src package name  = $(src_pkg_name)"
80         @echo "release           = $(release)"
81         @echo "revisions         = $(revisions)"
82         @echo "revision          = $(revision)"
83         @echo "uploadnum         = $(uploadnum)"
84         @echo "prev_revisions    = $(prev_revisions)"
85         @echo "prev_revision     = $(prev_revision)"
86         @echo "abinum            = $(abinum)"
87         @echo "gitver            = $(gitver)"
88         @echo "flavours          = $(flavours)"
89         @echo "skipabi           = $(skipabi)"
90         @echo "skipmodule        = $(skipmodule)"
91         @echo "skipdbg           = $(skipdbg)"
92         @echo "ubuntu_log_opts   = $(ubuntu_log_opts)"
93 ifneq ($(SUBLEVEL),)
94         @echo "SUBLEVEL          = $(SUBLEVEL)"
95 endif
96         @echo "CONCURRENCY_LEVEL = $(CONCURRENCY_LEVEL)"
97         @echo "bin package name  = $(bin_pkg_name)"
98         @echo "hdr package name  = $(hdrs_pkg_name)"
99         @echo "doc package name  = $(doc_pkg_name)"
100         @echo "do_doc_package            = $(do_doc_package)"
101         @echo "do_doc_package_content    = $(do_doc_package_content)"
102         @echo "do_source_package         = $(do_source_package)"
103         @echo "do_source_package_content = $(do_source_package_content)"
104         @echo "do_libc_dev_package       = $(do_libc_dev_package)"
105         @echo "do_flavour_image_package  = $(do_flavour_image_package)"
106         @echo "do_flavour_header_package = $(do_flavour_header_package)"
107         @echo "do_common_headers_indep   = $(do_common_headers_indep)"
108         @echo "do_full_source            = $(do_full_source)"
109         @echo "do_tools                  = $(do_tools)"
110         @echo "full_build                = $(full_build)"
111         @echo "libc_dev_version          = $(libc_dev_version)"
112         @echo "DEB_HOST_GNU_TYPE         = $(DEB_HOST_GNU_TYPE)"
113         @echo "DEB_BUILD_GNU_TYPE        = $(DEB_BUILD_GNU_TYPE)"
114         @echo "DEB_HOST_ARCH             = $(DEB_HOST_ARCH)"
115         @echo "DEB_BUILD_ARCH            = $(DEB_BUILD_ARCH)"
116         @echo "arch                      = $(arch)"
117         @echo "kmake                     = $(kmake)"
118
119 printchanges:
120         @baseCommit=$$(git log --pretty=format:'%H %s' | \
121                 awk '/UBUNTU: '".*Ubuntu-$(release)-$(prev_revision)"'$$/ { print $$1; exit }'); \
122                 git log "$$baseCommit"..HEAD | \
123                 perl -w -f $(DROOT)/scripts/misc/git-ubuntu-log $(ubuntu_log_opts)
124
125 insertchanges:
126         @perl -w -f $(DROOT)/scripts/misc/insert-changes.pl $(DROOT) $(DEBIAN) 
127
128 diffupstream:
129         @git diff-tree -p refs/remotes/linux-2.6/master..HEAD $(shell ls | grep -vE '^(ubuntu|$(DEBIAN)|\.git.*)')
130
131 startnewrelease:
132         dh_testdir
133         @nextminor=$(shell expr `echo $(revision) | awk -F. '{print $$2}'` + 1); \
134         now="$(shell date -R)"; \
135         echo "Creating new changelog set for $(abi_release).$$nextminor..."; \
136         echo -e "$(src_pkg_name) ($(abi_release).$$nextminor) UNRELEASED; urgency=low\n" > $(DEBIAN)/changelog.new; \
137         echo "  CHANGELOG: Do not edit directly. Autogenerated at release." >> \
138                 $(DEBIAN)/changelog.new; \
139         echo "  CHANGELOG: Use the printchanges target to see the curent changes." \
140                 >> $(DEBIAN)/changelog.new; \
141         echo "  CHANGELOG: Use the insertchanges target to create the final log." \
142                 >> $(DEBIAN)/changelog.new; \
143         echo -e "\n -- $$DEBFULLNAME <$$DEBEMAIL>  $$now\n" >> \
144                 $(DEBIAN)/changelog.new ; \
145         cat $(DEBIAN)/changelog >> $(DEBIAN)/changelog.new; \
146         mv $(DEBIAN)/changelog.new $(DEBIAN)/changelog
147