UBUNTU: Hyper-V KVP daemon -- add to the tools package
[linux-flexiantxendom0.git] / debian / rules.d / 2-binary-arch.mk
index 60b83d2..8308925 100644 (file)
@@ -401,6 +401,7 @@ ifeq ($(do_tools),true)
        if [ "$(arch)" = "amd64" ] || [ "$(arch)" = "i386" ]; then \
                cd $(builddir)/tools/tools/power/x86/x86_energy_perf_policy && make CROSS_COMPILE=$(CROSS_COMPILE); \
                cd $(builddir)/tools/tools/power/x86/turbostat && make CROSS_COMPILE=$(CROSS_COMPILE); \
+               cd $(builddir)/tools/tools/hv && make CROSS_COMPILE=$(CROSS_COMPILE) CFLAGS=-I../../include; \
        fi
 endif
        @touch $@
@@ -417,6 +418,9 @@ ifeq ($(do_tools),true)
                        $(toolspkgdir)/usr/bin/x86_energy_perf_policy_$(abi_release); \
                install -s -m755 $(builddir)/tools/tools/power/x86/turbostat/turbostat \
                        $(toolspkgdir)/usr/bin/turbostat_$(abi_release); \
+               install -d $(toolspkgdir)/usr/sbin; \
+               install -s -m755 $(builddir)/tools/tools/hv/hv_kvp_daemon \
+                       $(toolspkgdir)/usr/sbin/hv_kvp_daemon_$(abi_release); \
        fi
 endif