UBUNTU: [Config] Linearize module/abi checks
[linux-flexiantxendom0-natty.git] / debian / rules.d / 4-checks.mk
index d48c05d..d1c0ad9 100644 (file)
@@ -1,6 +1,4 @@
 # Check ABI for package against last release (if not same abinum)
-abi-%: $(abidir)/%
-       @# Empty for make to be happy
 $(abidir)/%: $(stampdir)/stamp-build-%
        install -d $(abidir)
        sed -e 's/^\(.\+\)[[:space:]]\+\(.\+\)[[:space:]]\(.\+\)$$/\3 \2 \1/'   \
@@ -11,9 +9,7 @@ abi-check-%: $(abidir)/%
                "$(prev_abidir)" "$(abidir)" "$(skipabi)"
 
 # Check the module list against the last release (always)
-module-%: $(abidir)/%.modules
-       @# Empty for make to be happy
-$(abidir)/%.modules: $(stampdir)/stamp-build-%
+$(abidir)/%.modules: abi-check-%
        install -d $(abidir)
        find $(builddir)/build-$*/ -name \*.ko | \
                sed -e 's/.*\/\([^\/]*\)\.ko/\1/' | sort > $@
@@ -22,7 +18,7 @@ module-check-%: $(abidir)/%.modules
        @perl -f $(DROOT)/scripts/module-check "$*" \
                "$(prev_abidir)" "$(abidir)" $(skipmodule)
 
-checks-%: abi-check-% module-check-%
+checks-%: module-check-%
        @# Will be calling more stuff later
 
 # Check the config against the known options list.