Fix changelog email address
[freerdp-ubuntu-pcb-backport.git] / freerdp.spec
1 # cmake
2 # make package_source
3 # rpmbuild -ta freerdp-<...>.tar.gz
4
5 Summary: Remote Desktop Protocol functionality
6 Name: freerdp
7 Version: 1.0.0
8 Release: 1%{?dist}
9 License: Apache License 2.0
10 Group: Applications/Communications
11 URL: http://www.freerdp.com/
12 Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
13 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14 BuildRequires:  openssl-devel
15 BuildRequires:  libX11-devel, libXcursor-devel, libXext-devel, libXinerama-devel, libXdamage-devel, libXv-devel, libxkbfile-devel
16 BuildRequires:  cups-devel
17 BuildRequires:  alsa-lib-devel
18 BuildRequires:  pcsc-lite-devel
19
20 %description
21 FreeRDP is a free implementation of the Remote Desktop Protocol (RDP)
22 according to the Microsoft Open Specifications.
23
24 %package -n xfreerdp
25 Summary: Remote Desktop Protocol client
26 Group: Applications/Communications
27 Requires: %{name}-libs = %{version}-%{release}, %{name}-plugins-standard = %{version}-%{release}
28 %description -n xfreerdp
29 FreeRDP is a free implementation of the Remote Desktop Protocol (RDP)
30 according to the Microsoft Open Specifications.
31
32 %package libs
33 Summary: Core libraries implementing the RDP protocol
34 Group: Applications/Communications
35 %description libs
36 libfreerdp-core can be embedded in applications.
37
38 libfreerdp-channels and libfreerdp-kbd might be convenient to use in X
39 applications together with libfreerdp-core.
40
41 libfreerdp-core can be extended with plugins handling RDP channels.
42
43 %package plugins-standard
44 Summary: Plugins for handling the standard RDP channels
45 Group: Applications/Communications
46 Requires: %{name}-libs = %{version}-%{release}
47 %description plugins-standard
48 A set of plugins to the channel manager implementing the standard virtual
49 channels extending RDP core functionality. For instance, sounds, clipboard
50 sync, disk/printer redirection, etc.
51
52 %package devel
53 Summary: Libraries and header files for embedding and extending freerdp
54 Group: Applications/Communications
55 Requires: %{name}-libs = %{version}-%{release}
56 Requires: pkgconfig
57 %description devel
58 Header files and unversioned libraries for libfreerdp-core, libfreerdp-channels,
59 libfreerdp-kbd, libfreerdp-cache, libfreerdp-codec, libfreerdp-rail,
60 libfreerdp-gdi and libfreerdp-utils.
61
62 %prep
63 %setup -q
64
65 %build
66 cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DWITH_PCSC=ON . 
67
68 make %{?_smp_mflags}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 make install DESTDIR=$RPM_BUILD_ROOT
73 rm -f $RPM_BUILD_ROOT%{_libdir}/{freerdp/,lib}*.{a,la} # FIXME: They shouldn't be installed in the first place
74
75 %post libs -p /sbin/ldconfig
76
77 %postun libs -p /sbin/ldconfig
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files -n xfreerdp
83 %defattr(-,root,root)
84 %{_bindir}/xfreerdp
85 %{_mandir}/*/*
86
87 %files libs
88 %defattr(-,root,root)
89 %doc LICENSE README
90 %{_libdir}/lib*.so.*
91 %dir %{_libdir}/freerdp
92 %{_datadir}/freerdp/
93
94 %files plugins-standard
95 %defattr(-,root,root)
96 %{_libdir}/freerdp/*.so
97
98 %files devel
99 %defattr(-,root,root)
100 %{_includedir}/freerdp/
101 %{_libdir}/lib*.so
102 %{_libdir}/pkgconfig/*
103
104 %changelog
105
106 * Tue Mar 16 2010 Mads Kiilerich <mads@kiilerich.com> - 0.0.1-1
107 - Initial "upstream" freerdp spec - made and tested for Fedora 12